Cisco路由器设备OSPF的路由汇总
bbin官网
bbin注册
admin
2020-05-15 01:16

  Cisco路由器设备OSPF的路由汇总

  【试验称号】

  Cisco路由器设备OSPF的路由汇总

  【试验目标】

  控制OSPF的域间路由汇总。

  【配景刻画】

  一个企业的收集工程师叨教你一个后果,他的收集的路由器回收了多条地址延续路由,他想让路由器提高任务效力,增加路由表范围,请你赐与支撑。

  【完胜利用】

  增加OSPF路由协定路由表的大年夜小。

  【试验拓扑】

  【试验装备】

  R2624路由器(2台)、V35DCE(1根)、V35DTE(1根)

  【试验步调】

  第一步:基本设备

  Red-Giant>en

  Red-Giant#conf t

  Red-Giant(config)#hostname R1

  R1(config)#interface serial 0

  R1(config-if)#ip address 192.168.12.1 255.255.255.0

  R1(config-if)#clock rate 64000

  R1(config-if)#no shutdown

  R1(config)#interface loopback 0

  R1(config-if)#ip add 172.16.1.1 255.255.255.0

  R1(config-if)#exi

  R1(config)#int loo 1

  R1(config-if)#ip address 172.16.2.1 255.255.255.0

  Red-Giant>enable

  Red-Giant#conf t

  Red-Giant(config)#hostname R2

  R2(config)#interface s0

  R2(config-if)#ip add 192.168.12.2 255.255.255.0

  R2(config-if)#no sh

  R2(config-if)#end

  验证测试:

  第二步:设备OSPF路由协定

  R1(config)#router ospf 1

  R1(config-router)#network 192.168.12.0 0.0.0.255 area 0

  R1(config-router)#network 172.16.1.0 0.0.0.255 area 2

  R1(config-router)#network 172.16.2.0 0.0.0.255 area 2

  R2(config)#router os 1

  R2(config-router)#net 192.168.12.0 0.0.0.255 area 0

  验证测试:R2#sh ip os nei

  Neighbor ID Pri State Dead Time Address Interface

  172.16.2.1 1 FULL/ – 00:00:36 192.168.12.1 Serial0

  第三步:区域间汇总路由

  R1(config-router)#area 2 range 172.16.0.0 255.255.252.0 !设备区域间会聚路由

  验证测试:

  R2#sh ip ro

  Codes: C – connected, S – static, R – RIP

  O – OSPF, IA – OSPF inter area

  E1 – OSPF external type 1, E2 – OSPF external type 2

  Gateway of last resort is not set

  C 192.168.10.0/24 is directly connected, FastEthernet0

  C 192.168.12.0/24 is directly connected, Serial0

  172.16.0.0/22 is subnetted, 1 subnets

  O IA 172.16.0.0 [110/49] via 192.168.12.1, 00:00:01, Serial0

  【留苦衷项】

  留心汇总地址的掩码。